Welcome! Becoming a registered user of ShortWingPipers.Org is free and easy! Click the "Register" link found in the upper right hand corner of this screen. It's easy and you can then join the fun posting and learning about Short Wing Pipers!

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Radio problem

  1. #1

    Join Date
    Jun 2012
    Posts
    45
    Post Thanks / Like

    Default Radio problem

    When I power up the avionic/radios on my tripacer i hear a loud buzzing in the headsets and when i key the mic/push to talk i loose all power to the radio stack. when i continue to key more than 2 or 3 times my avionics go off completely and then i need to shut down and i assume allow to cool and i then can power up again. ANY ideas?

    I'm thinking a weak relay or breaker but the loud buzzing in the headset has me a little perplexed.

  2. #2

    Join Date
    Mar 2017
    Location
    Frederick MD
    Posts
    283
    Post Thanks / Like

    Default Re: Radio problem

    Sounds like a bad ground.


    Sent from my iPhone using Tapatalk

  3. #3

    Join Date
    Jun 2012
    Posts
    45
    Post Thanks / Like

    Default Re: Radio problem

    A bad ground on the radio or intercom?

  4. #4

    Join Date
    Mar 2019
    Location
    Boise, Idaho , USA
    Posts
    1
    Post Thanks / Like

    Default Re: Radio problem

    Hi Bobbynick, I’m an avionics guy among other things. The buzzing in your headset seems like your audio system is suffering from lack of voltage to drive it. It could be a bad ground, but that would have to apply to your entire avionics system depending on how it was set up. It could also be on the 12volt power side. Take a voltmeter, connect the Black lead to your aircraft ground and put the red lead on the Bus side of the avionics circuit breaker with the master switch on.
    You should read battery voltage (at least 12.5 volts). Now turn on your avionics switch and key the radio to transmit. The voltage should stay the almost the same. If not, get back to me. Now put your voltmeter red lead on the other terminal of the avionics circuit breaker. Key the transmitter, the voltage should stay almost the same, if not you have a bad circuit breaker. If the voltage was still above 12 volts, go to the avionics switch, turn it off and put the red lead on the terminal that is still reading 12 volts. Then put the red lead on the other terminal, turn on the avionics switch, you should then still have over 12 volts...if not, the switch is bad. If you still have 12 volts, key the transmitter. If the voltage dies off to less than approx. 11 volts then you have a bad avionics switch or a bad crimp or burned connection somewhere in the power wires. Sometimes on these older aircraft there can be many old tarnished connections, crimp joints or fuse holders, that either need cleaning or replacing. If it gets beyond this basic trouble shooting mentioned above, you’re better off just taking it to an avionics shop to trouble shoot. if it does this same thing all the time it shouldn’t take a good avionics tech very long to find where the voltage drop is coming from, be it power or ground. Of course all of this is assuming that your battery capacity and charge is good. Get back to me if you have any questions.
    Ian

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •